After You Open an Outlook MSG File, You Can’t Re-Open, Delete, or Rename It

Problem

You’ve saved an Outlook email as an MSG file. If you open then close the file, you can’t re-open it, rename it, or delete it in Enterprise Organizer Pro. When you try to re-open the MSG file, you get an error message that says, in part:

Can’t open file: [filename]. The file may not exist, you may not have permission to open it, or it may be open in another program.

This only happens if Outlook is running, and it goes away if you close Outlook.

Cause

Once you’ve opened the file, Outlook keeps a lock on it, even if you close the file. Closing Outlook releases the lock. This isn’t normal behavior. Normally Outlook should release the lock as soon as you close the message. Any number of things could be causing the problem.

Solution #1

The simplest solution is to use Enterprise Organizer Pro’s "Preview" button instead of opening the MSG file. The previewer gives a faithful view of the email message without opening it. This is all that you need most of the time. Then if you need to extract an attachment or reply to the email, you can still open it in Outlook.

Solution #2

One reported problem is a corrupt Outlook "extend.dat" file. The solution is to force Outlook to rebuild the "extend.dat" file, which is fairly easy to do.

IMPORTANT: This is normally a safe operation, but you should still make sure you have your Outlook PST file backed up before you try it.

To rebuild your "extend.dat" file, do the following:

  1. Quit all programs, especially Outlook
  2. Click the Windows "Start" menu and select the "Find" or "Search" option
  3. In the search options, select "All Files and Folders"
  4. In the "Named" or "All or Part of the File Name" box, type extend.dat
  5. In the "Look In" list, make sure your local hard drives are selected
  6. Be sure to select "Include Subfolders"; this may be under the "Advanced" option
  7. Click "Search" or "Find Now"; let the search run until it’s finished
  8. In the search results, right-click on each extend.dat that’s found and select "Rename" from the pop-up menu; change the name to extend.old

Now restart Outlook to rebuild the "extend.dat" files. Once Outlook starts, you should be able to open and close MSG files repeatedly without getting the error.

Solution #3

Google Desktop Search has been reported to keep MSG files from opening. Removing Google Desktop or updating it to the latest release corrected the problem.

Solution #4

Some users have found that the Adobe Acrobat Office add-in can cause this problem. If you are comfortable editing the Registry, the following may fix the issue.

IMPORTANT: Editing the Registry can cause Windows to become unbootable. Edit the Registry at YOUR OWN RISK. We cannot assume any responsibility or liability for anything you do in the Registry or for carrying out the following procedure.

  1. Close Outlook
  2. Open the Windows Registry Editor (you can go to the "Run" option in the Start menu and enter "regedit")
  3. Locate and select "HKEY_LOCAL_MACHINESOFTWAREMicrosoftOfficeOutlookAddinsPDFMOutlook.PDFMOutlook"
  4. Locate and select the "LoadBehavior" option
  5. Go to the "Edit" menu and select "Modify"
  6. Change the value from 3 to 2
  7. Click OK
  8. Close the Registry Editor
  9. Restart Outlook
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